2006/03/01 記述 ※注意※−この文章を読むにあたって− 以下のことに同意をしてください。 「ここに書かれている文章は、私の解釈に誤りがある可能性が  大いにあるので、なるべく疑って読むようにしてください。」 要するに自己責任でお願いしますね。間違いのご指摘は大歓迎です。。 ■JavaScript とは・・? JavaScript の元は Netscape Communications 社が開発した LiveScript です。 この LiveScript はいろいろあって Sun Microsystems 社と開発を共同で行うことになりました。 そして Netscape Navigator 2.0β から搭載されていた LiveScript ですが、 共同開発をしていた Sun 社の Java の人気から Sun 社から許可を取り、 名前を途中で LiveScript から今の JavaScript に変更するに至りました。 そして JavaScript 1.0 を搭載した NN 2.0 が公開された後、 Internet Explorer 3.0 にも JavaScript らしきものが搭載されました。 ■ECMAScript と RFC 1738 また Netscape 社は JavaScript 1.1 を発表した後、ヨーロッパの標準化団体 ECMA (European Computer Manufacturer's Association) に JavaScript の標準化を要請しました。 そしてその結果 JavaScript 1.1 を元に ECMA TC39 は ECMA-262 (ECMAScript) を制定しました。 Microsoft 社と Netscape 社は、ともにこの規格 ECMAScript を採用することを発表しました。 しかしながら、ここで問題となったのは ECMA-262 に規定されている escape/unescape に関する仕様です。 ECMA では escape 及び unescape には Unicode を用いると決めました。が、その実装方法に問題がありました。 ECMA-262 では Unicode エンコーディング が 0xFF 以下の文字は 16進数 の数字二つを用いた "%HH" 形式を使い、 また 0xFF よりも大きい文字コードの場合には 16進数 の数字四つを用いた "%uHHHH" 形式を使います。(H = hexadecimal) しかし、この方式 "%uHHHH" は "RFC 1738 Uniform Resource Locators" で定められている方法には載っていません。 ちなみに従来の escape/unescape では ISO Latin-1 (8859-1) に基づく 16進数 エンコーディング を行っていました。 ところで [ECMA-262] と [RFC 1738] の違いは何なのでしょう?(以下参考文献 "Escape" より引用。) ・[RFC 1738] ではエンコードされない "$'!()," が [ECMA-262] ではエンコードされる。 ・[RFC 1738] ではエンコードされる "@/" が [ECMA-262] ではエンコードされない。 ・0xFF より大きな文字が [RFC 1738] では "%HH%HH", [ECMA-262] では "%uHHHH" でエンコードされる。 この3番目のものが、一番厄介なものです。ややこしくしてしまった原因とも言えるでしょう。 ■IEとNCの実装の違い IE 4.0 で搭載された JScript 3.0 は ECMA-262 に準拠した仕様を実装したもので、"%uHHHH"形式をサポートします。 しかし、Netscape 社は ECMA-262 に従わず、従来の方式である ISO Latin-1 を使用すると決定したため、 Netscape Communicator 4.06 以降で用いられている JavaScript 1.3 でも、"%uHHHH"形式をサポートしていません。 ちなみにこの "%uHHHH" 形式をサポートした場合 URL エスケープ が出来なくなってしまいます。 この二つの実装の違いが escape/unescape 関数に関して混乱をもたらすものとなりました。 ■Mozilla の場合 ◆そもそも Mozilla とは・・? 「1998年1月22日 Netscape 社は Netscape Communicator Standard Edition 5.0 のソースコードを 修正や再配布目的の場合、無料で利用できるようにすると発表しました。」(Mozilla Open Source FAQ) mozilla.org は当初このソースコードに基づいて Mozilla の開発を行っていたのですが、 そのソースコードには古い部分が多かったため Mozilla と平行して開発が行われていた新しい レイアウトエンジン NGLayout を搭載することにし、途中でソースコードの書き直しを決定します。 そしてその結果、新しい Webブラウザ を開発する Sea Monkey プロジェクト が発足しました。 ちなみに Gecko とは レイアウトエンジン NGLayout と クロスプラットフォームツールキット XPFE をあわせたものをさします。 Mozilla の詳細に関しては以下のURIが参考になります。 ttp://www.mozilla.gr.jp/docs/beginmoz-1.4/ ◆Netscape 社の Webブラウザ Netscape 社は Netscape Communicator 5 として Mozilla の開発を行っていたのですが 途中で NC5 のブラウザエンジンを破棄したため NC5 は発表されず、代わりに Netscape 6 が 発表されるに至りました。しかし、開発途中の Mozilla を搭載していた Netscape 6.0 には 不具合が多く評判はよくないようです。(Netscape 6 以降 Gecko を搭載しています。) ここで Netscape 社の Webブラウザ の名称についてまとめます。 『Netscape Navigator』は 3 までの名称。 『Netscape Communicator』は 4 から 5 までで、いろいろなソフトを同梱したことで付けた名称。 『Netscape 6/7』は、ユーザーの名前に関する認知度が低かったため変更した名称。 『Netscape Browser 8』は、『Firefox 1.0.x』をベースにして開発したため付けた名称。 ◆Mozilla の 仕様 詳細に関しては、参考元(ttp://www.felix.jp/~yugo/js/guide/escape.html)を見ていただきたい。 以下に要点をまとめたものを書いておく。 ・Mozilla が使用する JavaScript engine SpiderMonkey は ECMA-262 準拠 ・Mozilla では起動時に SpiderMonkey の escape/unescape をいったん定義するが、  その後 DOM の escape/unescape で SpiderMonkey の定義を上書きする。 (今でも DOM による上書きを行っているかどうかは調べていないのでわかりません。) ・『Bug 22594』の指摘を受け DOM 側の escape/unescape の仕様を ISO Latin-1 に変更。(2000年1月〜) ・さらに『Bug 44272』『Bug 225695』の指摘を受け元の ECMA-262 に準拠した仕様に戻される。(2004年1月〜) Bugzilla ttp://www.bugzilla.org/ ■ で escape/unescape は・・? 結局、escape/unescape 関数は『ECMA-262 3rd Edition』で、正式な仕様の一部ではなくなりました。 ※IE, Netscape, Mozilla, Opera の最新版では、"%uHHHH" 形式に対応しているようです。 『ECMA-262 3rd Edition』では encodeURI, decodeURI, endodeURIComponent, decodeURIComponent 関数が追加されています。 これらの関数は "RFC 2396 Uniform Resource Identifiers" に準拠しており、 名前の通り URI の エンコード/デコード を行う関数です。(UTF-8 による) "Component" が付くものとつかないものの違いは【予約文字の扱い】にあります。 "RFC 2396 Uniform Resource Identifiers" "RFC 2718 Guidelines for new URL Schemes" などによると、エンコード方法の統一が望ましく特に問題がなければ 『UTF-8 で %HH 形式の使用』を推奨しているようです。 ちなみに現在の URI の最新の定義は【RFC 3986】のようです。 【RFC 2396】と【RFC 2732】は廃止されました。 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ この文章は以下の文章を元に作成されました。※"Internet Archive"を利用してください。 ・「Escape」最終更新日: 2000年9月24日(日) ttp://www.felix.jp/~yugo/js/guide/escape.html MSIE/7 MSIE/6 MSIE/5 MSIE/4 Netscape/7 Netscape/4 Netscape/3 Opera/8 Opera/7 Opera/6 [HTTP_ACCEPT] => text/html, image/png, image/jpeg, image/gif, image/x-xbitmap, */* [HTTP_ACCEPT_CHARSET] => windows-1252;q=1.0, utf-8;q=1.0, utf-16;q=1.0, iso-8859-1;q=0.6, *;q=0.1 [HTTP_ACCEPT_ENCODING] => deflate, gzip, x-gzip, identity, *;q=0 [HTTP_ACCEPT_LANGUAGE] => en [HTTP_CACHE_CONTROL] => no-cache [HTTP_CONNECTION] => Keep-Alive, TE [HTTP_COOKIE] => namec=aho [HTTP_COOKIE2] => $Version=\"1\" [HTTP_TE] => deflate, gzip, chunked, identity, trailers [HTTP_USER_AGENT] => Mozilla/4.0 (compatible; MSIE 5.0; Windows 2000) Opera 6.0 [en] [HTTP_ACCEPT] => */* [HTTP_ACCEPT_ENCODING] => gzip, deflate [HTTP_ACCEPT_LANGUAGE] => ja [HTTP_CONNECTION] => Keep-Alive [HTTP_COOKIE] => pwdc=91069457; namec=%82%A0%82%87%83%94%82%9F [HTTP_USER_AGENT] => Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Maxthon; .NET CLR 2.0.50727) [HTTP_ACCEPT] => */* [HTTP_ACCEPT_ENCODING] => gzip, deflate [HTTP_ACCEPT_LANGUAGE] => ja [HTTP_CONNECTION] => Keep-Alive [HTTP_COOKIE] => pwdc=91069457; namec=%u3042%uff47%u30f4%u3041 [HTTP_USER_AGENT] => Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Maxthon; .NET CLR 2.0.50727) Mozilla/5.0 (Windows; U; Windows NT 5.0; ja; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1 [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5 [HTTP_ACCEPT_CHARSET] => Shift_JIS,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => ja,en-us;q=0.7,en;q=0.3 [HTTP_CONNECTION] => keep-alive [HTTP_KEEP_ALIVE] => 300 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; ja; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1 Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 2.0.50727) Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; ja) Opera 8.52 [HTTP_ACCEPT] => text/html, application/xml;q=0.9, application/xhtml+xml, image/png, image/jpeg, image/gif, image/x-xbitmap, */*;q=0.1 [HTTP_ACCEPT_CHARSET] => shift_jis, utf-8, utf-16, iso-8859-1;q=0.6, *;q=0.1 [HTTP_ACCEPT_ENCODING] => deflate, gzip, x-gzip, identity, *;q=0 [HTTP_ACCEPT_LANGUAGE] => ja,en;q=0.9 [HTTP_CONNECTION] => Keep-Alive, TE [HTTP_TE] => deflate, gzip, chunked, identity, trailers [HTTP_USER_AGENT] => Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; ja) Opera 8.52 Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Geko/20051002 Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050423 [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CONNECTION] => keep-alive [HTTP_KEEP_ALIVE] => 300 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b) Gecko/20050423 Mozilla/5.0 (Windows; U; Windows NT 5.0; ja-JP; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1 [HTTP_ACCEPT_CHARSET] => Shift_JIS,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => ja [HTTP_CONNECTION] => keep-alive [HTTP_KEEP_ALIVE] => 300 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; ja-JP; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) [HTTP_ACCEPT] => */* [HTTP_ACCEPT_ENCODING] => gzip, deflate [HTTP_ACCEPT_LANGUAGE] => ja [HTTP_CONNECTION] => Keep-Alive [HTTP_USER_AGENT] => Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 2.0.50727) Netscape/8.1 [HTTP_ACCEPT] => application/x-shockwave-flash,text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_KEEP_ALIVE] => 300 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20060127 Netscape/8.1 javascript NG [HTTP_ACCEPT] => */*;q=0.1,image/svg+xml,application/mathml+xml,application/xhtml+xml [HTTP_ACCEPT_ENCODING] => *,gzip [HTTP_CACHE_CONTROL] => no-cache [HTTP_CONNECTION] => TE [HTTP_PRAGMA] => no-cache [HTTP_TE] => trailers,deflate [HTTP_USER_AGENT] => amaya/9.4 libwww/5.4.0 HotJava [HTTP_ACCEPT] => text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2 [HTTP_CACHE_CONTROL] => no-cache [HTTP_CONNECTION] => keep-alive [HTTP_PRAGMA] => no-cache [HTTP_USER_AGENT] => Mozilla/3.0 (x86 [ja] Windows NT 5.0; Sun) [HTTP_ACCEPT] => text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2 [HTTP_CONNECTION] => keep-alive [HTTP_USER_AGENT] => Mozilla/5.0 (Java 1.5.0_05; Windows 2000 5.0 x86; ja_JP) ICEbrowser/v6_0_3 Java/1.5.0_05 [HTTP_ACCEPT] => text/html, text/plain, text/sgml, */*;q=0.01 [HTTP_ACCEPT_ENCODING] => gzip, compress, bzip2 [HTTP_ACCEPT_LANGUAGE] => ja [HTTP_USER_AGENT] => Lynx/2.8.6dev.16TH libwww-FM/2.14FM SSL-MM/1.4.1 OpenSSL/0.9.6l [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CONNECTION] => keep-alive [HTTP_KEEP_ALIVE] => 300 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050610 K-Meleon/0.9 [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5 [HTTP_ACCEPT_CHARSET] => Shift_JIS,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => ja,en-us;q=0.5 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_KEEP_ALIVE] => 300 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050922 Sylera/2.2.9 [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => namec=%u3042%uff47%u30f4%u3041 [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_REFERER] => http://f16.aaa.livedoor.jp/~moremoe/test2/ [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.1) Gecko/20060224 Flock/0.5.12 [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => namec=%u3042%uff47%u30f4%u3041 [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_REFERER] => http://f16.aaa.livedoor.jp/~moremoe/test2/ [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050815 Bagel/0.2.7 SeaMonkey/1.0a bug [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,text/css,*/*;q=0.1 [HTTP_ACCEPT_CHARSET] => ISO-8859-1, utf-8;q=0.66, *;q=0.66 [HTTP_ACCEPT_ENCODING] => gzip, deflate, compress;q=0.9 [HTTP_ACCEPT_LANGUAGE] => en-us, en;q=0.50 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => namec=%u3042%u307b [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_REFERER] => http://f16.aaa.livedoor.jp/~moremoe/test2/ [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020923 Phoenix/0.1 [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate,compress;q=0.9 [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => namec=%82%A0%82%D9 [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_REFERER] => http://f16.aaa.livedoor.jp/~moremoe/test2/ [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5 [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => namec=%82%A0%82%D9 [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_REFERER] => http://f16.aaa.livedoor.jp/~moremoe/test2/ [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1 [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => namec=%u3042%u307b [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_REFERER] => http://f16.aaa.livedoor.jp/~moremoe/test2/ [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7 [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => namec=%u3042%u307b; pwdc=19533582 [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) ok [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => namec=%u3042%u307b [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_REFERER] => http://f16.aaa.livedoor.jp/~moremoe/test2/ [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040210 Firefox/0.8 [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => pwdc=19533582; namec=%u3042%u307b [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax) ng [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => pwdc=19533582; namec=%u3042%u307b [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030925 ok [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1 [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7 [HTTP_ACCEPT_ENCODING] => gzip,deflate [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.5 [HTTP_CACHE_CONTROL] => max-age=0 [HTTP_CONNECTION] => keep-alive [HTTP_COOKIE] => namec=%u3042%u307b; pwdc=19533582 [HTTP_HOST] => f16.aaa.livedoor.jp [HTTP_KEEP_ALIVE] => 300 [HTTP_USER_AGENT] => Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113